Masalah : Eclipse error “Java compiler level does not match the version of the installed Java project facet”

Oleh : Reza Ervani

بسم الله الرحمن الرحيم

Jika kita mendapati pesan kesalahan seperti tampak pada gambar berikut :

Screenshot from 2014-04-21 17:52:22

Pesan ini muncul karena Versi Java yang kita gunakan tidak sesuai dengan versi Facet yang ada. Kita bisa periksa dengan Project – Properties :

Screenshot from 2014-04-21 18:31:10

Lalu kita cek versi Project Facet :

Screenshot from 2014-04-21 18:31:43

Catatan : 

Bug 430637 – [hotbug] Java Version 1.8 of project facet java does not exist in Kepler SR2

Terdapat Bug untuk Java Version 1.8. Untuk itu disarankan untuk mengunduh Eclipse Kepler SR2 packages with Java™ 8 patches : http://www.eclipse.org/downloads/index-java8.php

Atau anda juga dapat menginstall patch yang disediakan oleh Eclipse di http://download.eclipse.org/eclipse/downloads/

Sebagaimana dicantumkan pada halaman tersebut :

Screenshot from 2014-04-21 18:50:50

Semoga membantu

About Reza Ervani
Adalah pendiri programming.rezaervani.com -

About Reza Ervani 380 Articles
Adalah pendiri programming.rezaervani.com -

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.